به سایت خودتان خوش آمـدید
به سایت هوشیار خوش آمـدید
به سایت هوشیار خوش آمـدید
به سایت خودتان خوش آمـدید
  1. خانه
  2. آموزش کامپیوتر
  3. آموزش تخصصی شبکه : آدرس دهی داینامیک قسمت ششم

آموزش تخصصی شبکه : آدرس دهی داینامیک قسمت ششم

آموزش تخصصی شبکه
آموزش تخصصی شبکه : آدرس دهی داینامیک قسمت ششم

در این مطلب (آموزش تخصصی شبکه : آدرس دهی داینامیک قسمت ششم) همراه ما باشید.

در آموزش قبل نحوه آدرس دهی داینامیک و طریقه ایجاد VTP را به شما عزیزان آموزش دادیم. ولی این جلسه می خواهیم برای شبکه های نسبتا شلوغ یا به عبارتی شبکه هایی که دارای سوئیچ ها و کلاینت های فراوان هستند، مثالی زده و همراه با کارگاه عملی به شما آموزش دهیم، پس با سایت هوشیار همراه باشید.

اگر در اینترنت جستجویی کنید خواهید دید که اکثر آموزش های جامع شبکه، دوره ای و با پرداخت هزینه هایی نسبتا سنگین انجام می شود. ولی هدف ما آموزش رایگان برای کسانی است که علاقه مند به یادگیری در حوزه شبکه می باشند.

شرح مساله:

در این مثال ما 5 سوئیچ و 8 کلاینت انتخاب کرده ایم که می خواهیم به روش داینامیک و استفاده از VTP و VLan آن ها را شبکه کنیم.

آموزش تخصصی شبکه : آدرس دهی داینامیک قسمت ششم
آموزش تخصصی شبکه : آدرس دهی داینامیک قسمت ششم

ابتدا می بایست یک سوئیچ 3560 و 4 عدد سوئیچ 2960 و 8 کلاینت به محیط نرم افزار سیکو پکت تریسر اضافه می کنیم.

برای اتصال سوئیچ به سوئیچ از کابل کراس آور (cross over) استفاده می کنیم، و برای اتصال سوئیچ به کلاینت از کابل copper straight through استفاده می کنیم.

آموزش تخصصی شبکه : آدرس دهی داینامیک قسمت ششم
آموزش تخصصی شبکه : آدرس دهی داینامیک قسمت ششم

آرایش سوئیچ ها در شبکه بدین شکل است (طبق تصویر):

از پورت 0/1 سوئیچ 3560 به پورت 0/1 سوئیچ 2960 دوم (سمت چپ)

از پورت 0/2 سوئیچ 3560 به پورت 0/1 سوئیچ 2960 چهارم (سمت راست)

از پورت 0/2 سوئیچ 2960 دوم به پورت 0/1 سوئیچ 2960 سوم

از پورت 0/2 سوئیچ 2960 چهارم به پورت 0/2 سوئیچ 2960 پنجم

بعد از اتصال سوئیچ ها با یکدیگر نوبت به کلاینت ها می رسد بدین ترتیب:

از پورت 0/3 و 0/4 سوئیچ 2960 دومی به دو کلاینت

از پورت 0/3 و 0/2 سوئیچ 2960 سومی به دو کلاینت

از پورت 0/3 و 0/4 سوئیچ 2960 چهارمی به دو کلاینت

از پورت 0/3 و 0/1 سوئیچ 2960 پنجمی به دو کلاینت

حالا می بایست بر روی هر کلاینت کلیک کرده و در بخش Desktop و گزینه IP Configuration رفته و DHCP را برای هر هشت کلاینت فعال کنیم.

امروز می خواهیم شبکه را طوری تنظیم کنیم که آی پی به صورت خودکار یا داینامیک به کلاینت ها اختصاص داده شود و مثلا در صورت اضافه شدن کلاینت به شبکه، خود شبکه آی پی به صورت خودکار به کلاینت ها اختصاص بده و لازم به تنظیم دستی نباشه.

خب وارد سوئیچ ۳۵۶۰ می شویم و در بخش CLI کدهای زیر رو وارد می کنیم.

en
conf t
int fa 0/1
switchport mode access
switchport mode trunk
exit
int fa 0/2
switchport mode access
switchport mode trunk
exit

با دستورات بالا ارتباط سوئیچ ۳۵۶۰ را با سوئیچ های ۲۹۶۰ دوم و چهارم برقرار می کنیم. حالا برای برقراری ارتباط بین دو سوئیچ دیگر به CLI سوئیچ دوم و چهارم رفته و دستورات زیر را برای هر یک اجرا می کنیم.

برای سوئیچ 2 و 4

en
conf t
int fa 0/2
switchport mode access
switchport mode trunk
exit

بعد از اتصال تمام سوئیچ ها با هم، به سوئیچ 3560 رفته و شروع به ساخت VLAN و VTP می کنیم. ما می خواهیم 4 وی لن (VLAN) برای شبکه خود ایجاد کنیم پس دستورات زیر را اجرا می کنیم.

نکته: به طور پیش فرض VLAN1 داخل سوئیچ فعال می باشد، پس ما از VLAN شماره دو به بعد استفاده می کنیم.

enable
config terminal
vlan 2
exit
vlan 3
exit

vlan 4

exit

vlan 5

exit

حالا می بایست که VTP را در سویئچ 3560 راه اندازی کنیم. مانند زیر


vtp domin hassi.ir
vtp mode server
vtp password 123
vtp version 2
exit

نکته 2 : ساخت VLAN تنها یک بار آن هم در سوئیچ اصلی 3560 انجام می شود. و برای سایر سوئیچ ها نیازی به ساخت وی لن نیست.

حالا به چهار سوئیچ 2960 باقی مانده رفته و VTP را برای هر یک به طور جداگانه راه اندازی می کنیم.

به هر 4 سوئیچ رفته و کدهای زیر را در CLI آن وارد می کنیم.

enable
config terminal
vtp domin hassi.ir
vtp mode server
vtp password 123
vtp version 2
exit

در گام بعد دوباره به هر 4 سوئیچ 2960 رفته و کلاینت های متصل شده را به داخل VLAN میندازیم.

اموزش شبکه کردن چند سیستم : گروه بندی کامپیوترها قسمت دوم
بدین ترتیب:

کلاینت های سوئیچ 2960 دوم به داخل Vlan 2

کلاینت های سوئیچ 2960 سوم به داخل Vlan 3

کلاینت های سوئیچ 2960 چهارم به داخل Vlan 4

کلاینت های سوئیچ 2960 پنجم به داخل Vlan 5

ارتباط Vlan: یعنی ارتباط کلاینت های داخل vlan ها را با هم برقرار می کند و همدیگر را می شناسند یا به عبارت دیگر شبکه می شوند.

برای سوئیچ 2960 دوم و سوم بدین شکل می باشد:


enable

config terminal

int ra fa 0/3-4

switchport mode access

switchport access vlan 2

exit

enable

conf t

int ra fa 0/2-3

switchport mode access

switchport access vlan 3

exit

برای سوئیچ 2960 چهارم و پنچم بدین شکل می باشد:


enable

config terminal

int ra fa 0/3-4

switchport mode access

switchport access vlan 2

exit

enable

config terminal

int ra fa 0/1-3

switchport mode access

switchport access vlan 3

exit

کار ما تقریبا با سوئیچ های 2960 به پایان رسیده است و حالا می بایست به سوئیچ 3560 رفته و عملیات آخر را انجام دهیم.

بعد از اجرای مراحل فوق، اولین کاری که باید در این سوئیچ انجام دهیم اختصاص دادن رنج آی پی خودکار به کلاینت ها می باشد. پس دستورات ذیل را وارد می کنیم.

enable

config terminal

ip dhcp excluded-address 192.168.1.100

ip dhcp excluded-address 192.168.2.100

ip dhcp excluded-address 192.168.3.100

ip dhcp excluded-address 192.168.4.100

حالا نوبت به آن رسیده که وارد Vlan ها شده و به آن ها آدرس IP به همراه DNS و دیفالت گیت وی اختصاص دهیم.

ip dhcp pool vlan2


network 192.168.1.0 255.255.255.0

default-router 192.168.1.254

dns-server 2.2.2.2

exit

ip dhcp pool vlan3


network 192.168.2.0 255.255.255.0

default-router 192.168.2.254

dns-server 3.3.3.3

exit

ip dhcp pool vlan4


network 192.168.3.0 255.255.255.0

default-router 192.168.3.254

dns-server 4.4.4.4

exit

ip dhcp pool vlan5


network 192.168.4.0 255.255.255.0

default-router 192.168.4.254

dns-server 5.5.5.5

exit

حالا اگر می خواهید ارتباط دو vlan (دو و سه ) را برقرار کنید به طوری که همه ی کلاینت ها همدیگر را بشناسند باید دستورات زیر را در سوئیچ اصلی ۳۵۶۰ اجرا کنیم.

int vlan 2

ip address 192.68.1.254 255.255.255.0

exit

int vlan 3

ip address 192.68.2.254 255.255.255.0

exit

int vlan 4

ip address 192.68.3.254 255.255.255.0

exit

int vlan 5

ip address 192.68.4.254 255.255.255.0

exit

به عنوان آخرین دستور در سوئیچ اصلی ۳۵۶۰ دستور ip routing را تایپ نموده و اینتر را بزنید تا مسیر یابی بین سوئیچ ها انجام شود.

حالا اگر یک یا چند کلاینت دیگه به شبکه متصل کنیم فقط کافیست DHCP را فعال کنیم و کلاینت ها را داخل VLAN بندازیم.

نکته نهایی : برای این که در تایپ دستورات دچار مشکل نشوید پیشنهاد می کنیم از کلید Tab کیبورد استفاده کنید. به طور مثال هنگام تایپ switchport mode access می توانید sw را تایپ کرده و سپس کلید تَب (Tab) کیبورد را بزنید تا به طور خودکار دستور کامل شود.

* نکات دستوری

دستور en مخفف enable می باشد

دستور conf t مخفف config terminal می باشد

دستور int fa مخفف interface fastethernet می باشد

دستور int ra fa مخفف interface range fastethernet می باشد

امیدواریم از این مقاله آموزشی نهایت استفاده را برده باشید. در جلسه بعد نحوه کار با روتر را به شما عزیزان آموزش خواهیم داد.

درصورت داشتن هر گونه سوال و مشکل در بخش نظرات اعلام نموده تا پاسخ داده شود.

در پایان این جلسه، یکی از جامع ترین و کاربردی ترین کتاب های آموزشی در حوزه شبکه را برای شما عزیزان آماده کرده ایم که با مطالعه آن میتوانید مهارت خود را در این زمینه افزایش دهید.

نام کتاب : آموزشی مدیر شبکه 2

سرفصل های این کتاب: نصب و راه اندازی ویندوز سرور 2016 – راه اندازی اتاق سرور به همراه تجهیزات آن – نصب و راه اندازی سیستم سنتر 2016 – نصب و راه اندازی دوربین مداربسته – آنتی ویروس تحت شبکه – امنیت در شبکه – سیستم سانترال – نکات و اصول پیاده سازی شبکه در محیط واقعی و ….

لینک دانلود


مدرس : حسن هوشیار آدینه زاده مهندس فناوری اطلاعات

دیدگاهتان را بنویسید

نشانی ایمیل شما منتشر نخواهد شد. بخش‌های موردنیاز علامت‌گذاری شده‌اند *

این فیلد را پر کنید
این فیلد را پر کنید
لطفاً یک نشانی ایمیل معتبر بنویسید.

فهرست