به سایت خودتان خوش آمـدید
به سایت هوشیار خوش آمـدید
به سایت هوشیار خوش آمـدید
به سایت خودتان خوش آمـدید
  1. خانه
  2. آموزش کامپیوتر
  3. اموزش شبکه کردن سیستم قسمت پنجم

اموزش شبکه کردن :آدرس دهی داینامیک و ایجاد vtp قسمت پنجم

سلام دوستان عزیز ، در این قسمت ( اموزش شبکه کردن سیستم قسمت پنجم ) می خواهیم شما را با آدرس دهی داینامیک به کلاینت ها و ساختن vtp در سوئیچ آشنا کنیم.

در قسمت قبل نحوه اتصال دو سوئیچ را به شما آموزش دادیم .

VTP چیست؟

زمانی که قصد ساختن vlan ها را داریم انجام این عملیات در شبکه هایی که تعداد سوییچ های آن زیاد باشد , معرفی این vlan ها به تک تک سوئیچ ها کاری بسیار دشوار و زمانبر است. برای حل این مساله سیسکو اقدام به معرفی پروتکلی به نام vtp نمود.کار vtp انتقال vlan های مختلف به سوئیچ هایی است که در جوار یکدیگر قرار دارند که به ان vtp domain می گویند.سوئیچ هایی که بخواهند در محدوده ی vtp domain باشند باید یکی از سه حالت زیر را داشته باشند :

  1. vtp server : این سوئیچ مرجع حذف و اضافه و تعریف vlan هاست.در واقع فقط این سوئیچ قادر به اعمال تغییرات vlan database در ان vtp domain میباشد یعنی هر vlan جدید ابتدا در این سوئیچ تعریف میشود.
  2. vtp client : سوئیچ هایی که client هستند تنها قادر هستند vtp database ها را از vtp server دریافت و انها را بخوانند و از پورت های trunk خود انتقال دهند و هیچ تغییری نمی توانند در آن ایجاد کنند و نمی توان vlan جدید روی ان ساخت و یا حذف کرد.
  3. vtp transparent : این سوئیچ ها می توانند vlan database خود را داشته باشند ولی نمی توانند به بقیه ارسال کنند ولی میتوانند اطلاعات vlan database های دریافتی را از خود عبور دهند.

در هریک از vtp domain ها یک مقدار 32 بیتی وجود دارد که به ان configuration revision می گویند و نشان دهنده ی سطح تغییرات یک vtp است.

خب تا این جا فهمیدیم که vtp در شبکه چکاره است.حالا می ریم سراغ آزمایش عملی، پس با ما همراه باشید.

نرم افزاری که ما استفاده می کنیم برنامه شبیه ساز شبکه یعنی سیسکو پکت تریسر (cisco packet tracer) می باشد.

حالا شروع می کنیم، نرم افزار پکت تریسر رو باز کنید و یک سوئیچ 3560 و دو سوئیچ 2960 و چهار کلاینت به محیط نرم افزار بیاورید.(طبق شکل زیر)

اموزش شبکه کردن سیستم قسمت پنجم
هوشیار

برای اتصال سوئیچ به سوئیچ از کابل کراس آور (cross over) استفاده می کنیم، و برای اتصال سوئیچ به کلاینت از کابل copper straight through استفاده می کنیم.

برای اتصال از پورت 0/1 سوئیچ 3560 به پورت 0/1 سوئیچ 2960 اولی (سمت چپ تصویر) وصل می کنیم.

و از پورت 0/2 سوئیچ 3560 برای پورت 0/1 سوئیچ 2960 دومی (سمت راست تصویر) وصل می کنیم.

طبق شکل زیر

اموزش شبکه کردن سیستم قسمت پنجم
هوشیار

برای اتصال سوئیچ 2960 به کلاینت هم از پورت 0/2 و 0/3 سوئیچ به کلاینت اولی و دومی استفاده نمایید.(برای هر دو طرف کلاینت)

خب در آموزش های قبلی از اختصاص دادن آی پی دستی یا استاتیک استفاده می کردیم.

اما امروز می خواهیم شبکه ( اموزش شبکه کردن سیستم قسمت پنجم) را طوری تنظیم کنیم که آی پی به صورت خودکار یا داینامیک به کلاینت ها اختصاص داده شود و مثلا در صورت اضافه شدن کلاینت به شبکه، خود شبکه آی پی به صورت خودکار به کلاینت ها اختصاص بده و لازم به تنظیم دستی نباشه.

خب وارد سوئیچ 3560 می شویم و در بخش CLI کدهای زیر رو وارد می کنیم.

en
conf t
int fa 0/1
switchport mode access
switchport mode trunk
exit
int fa 0/2
switchport mode access
switchport mode trunk
exit

با دستورات بالا ارتباط سوئیچ 3560 را با سوئیچ های 2960 برقرار می کنیم.

حالا طبق دستورات زیر دو تا Vlan درست می کنیم. و سپس شروع به ساخت vtp می کنیم.

enable
config terminal
vlan 2
exit
vlan 3
exit
vtp domin hassi.ir
vtp mode server
vtp password 123
vtp version 2
exit

اموزش شبکه کردن سیستم قسمت پنجم
هوشیار

خب حالا به دو سوئیچ 2960 پایینی (در شکل بالا) رفته و برای هر دو سوئیچ دستورات زیر رو در بخش CLI وارد می کنیم.(باید برای دو سوئیچ 2960 نیز vtp درست کنیم همانند سوئیچ 3560)

کدام مدل هاست مناسب سایت من است؟

enable
config terminal
vtp domin hassi.ir
vtp mode client
vtp password 123
vtp version 2
exit

اگر در دستورات بالا توجه کنید در خط vtp mode client به جای server ما client گذاشتیم ،چون دو سوئیچ 2960 به کلاینت ها متصل می باشد، ولی سوئیچ 3560 به دو سوئیچ 2960 اتصال دارد.

نحوه اختصاص دادن IP داینامیک

بر روی هر کلاینت (هر چهار کلاینت ) در محیط نرم افزار کلیک نموده و در بخش IP Configuration گزینه ی DHCP را فعال کنید.

اموزش شبکه کردن سیستم قسمت پنجم
هوشیار

خب حالا داخل هر دو سوئیچ 2960 شده ،دربخش cli با دستورات زیر کلاینت ها را داخل vlan بندازید.

en

config terminal

int fa 0/2

switchport mode access

switchport access vlan 2

exit

int fa 0/3

switchport mode access

switchport access vlan 3

exit

حالا به سوئیچ 2960 مقابل رفته و همین دستورات بالا را در محیط cli وارد نمایید.

خب ما تا اینجا vlan ها رو درست کردیم ، کلاینت ها را آی پی DHCP دادیم ، VTP رو در هر سه سوئیچ پیاده کردیم ارتباط سه سوئیچ رو برقرار کردیم و کلاینت ها را داخل دو vlan دو و سه انداختیم.

حالا باید به سوئیچ مرکزی یعنی 3560 رفته و به کلاینت ها به طور اتوماتیک آی پی اختصاص بدیم.

روی سوئیچ 3560 کلیک کرده و در بخش cli دستورات زیر را وارد نمایید.

en

conf t

ip dhcp excluded-address 192.168.1.100

ip dhcp excluded-address 192.168.2.100

ip dhcp pool vlan 2

network 192.168.1.0 255.255.255.0

default-router 192.168.1.254

dns-server 2.2.2.2

exit

ip dhcp pool vlan3

network 192.168.2.0 255.255.255.0

default-router 192.168.2.254

dns-server 3.3.3.3

exit

دستورات بالا یک رنج آی پی برای وی لن ها در نظر گرفته و به کلاینت های داخل وی لن آی پی در بین یک رنج خاص که خودمان تعیین می کنیم اختصاص می دهد.(همینطور دیفالت روتر و دی ان اس به وی لن ها اختصاص داده می شود.)

خب تقریبا کار ما تمومه ، حالا برید روی کلاینت ها کلیک کرده و ببینید آیا IP و DNS و Default Router به آن ها اختصاص داده شده یا نه.

برای ازمایش باید پاکت از یک کلاینت به کلاینت دیگه بفرستید که ما به طور یک در میان سیستم ها را شبکه کردیم.

یعنی از کلاینت اول به سوم ارتباط برقرار شده و از کلاینت دوم به چهارم.

ارتباط Vlan ها یعنی ارتباط کلاینت های داخل vlan ها را با هم برقرار می کند و همدیگر را می شناسند یا به عبارت دیگر شبکه می شوند.

حالا اگر می خواهید ارتباط دو vlan ( دو و سه ) را برقرار کنید به طوری که همه ی کلاینت ها همدیگر را بشناسند باید دستورات زیر را در سوئیچ اصلی 3560 اجرا کنیم.

int vlan 2

ip address 192.68.1.254 255.255.255.0

int vlan 3

ip address 192.68.2.254 255.255.255.0

exit

به عنوان آخرین دستور در سوئیچ اصلی 3560 دستور ip routing را تایپ نموده و اینتر را بزنید تا مسیر یابی بین سوئیچ ها انجام شود.

حالا اگر یک یا چند کلاینت دیگه به شبکه متصل کنیم فقط کافیست DHCP را فعال کنیم و کلاینت ها را داخل VLAN بندازیم.

نکته نهایی : برای این که در تایپ دستورات دچار مشکل نشوید پیشنهاد می کنیم از کلید Tab کیبورد استفاده کنید. به طور مثال هنگام تایپ switchport mode access می توانید sw را تایپ کرده و سپس کلید تَب (Tab) کیبورد را بزنید تا به طور خودکار دستور کامل شود.

* نکات دستوری

دستور en مخفف enable می باشد

دستور conf t مخفف config terminal می باشد

دستور int fa مخفف interface fastethernet می باشد

دستور int ra fa مخفف interface range fastethernet می باشد

امیدواریم از این آموزش ( اموزش شبکه کردن سیستم قسمت پنجم )نهایت استفاده را برده باشید.

درصورت داشتن هر گونه سوال و مشکل در بخش نظرات اعلام نموده تا پاسخ داده شود.


تهیه کننده : حسن هوشیار آدینه زاده کارشناس فناوری اطلاعات


3 دیدگاه. ارسال دیدگاه جدید

دیدگاهتان را بنویسید

نشانی ایمیل شما منتشر نخواهد شد. بخش‌های موردنیاز علامت‌گذاری شده‌اند *

این فیلد را پر کنید
این فیلد را پر کنید
لطفاً یک نشانی ایمیل معتبر بنویسید.

فهرست